[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Heimdal 0.3e building problem

>>>>> "Enrico" == Enrico Pelletta <enrico@it.kth.se> writes:

    Enrico> ... ... ../com_err/error.lo ../com_err/com_err.lo -R -L
    Enrico> -lcrypto ../../lib/asn1/libasn1.la
    Enrico> ../../lib/vers/libvers.la ../../lib/roken/libroken.la
    Enrico> -lcrypt -lresolv -lresolv libtool: link: only absolute
    Enrico> run-paths are allowed make[2]: *** [libkrb5.la] Error 1
    Enrico> make[2]: Leaving directory `/root/heimdal-0.3e/lib/krb5'
    Enrico> make[1]: *** [all-recursive] Error 1 make[1]: Leaving
    Enrico> directory `/root/heimdal-0.3e/lib' make: ***
    Enrico> [all-recursive] Error 1

    Enrico> I have already found some info about this problem on the
    Enrico> archive of the mailing list, but nothing worked. Is it
    Enrico> possible to solved this problem?  Should I use a different
    Enrico> heimdal release?  Thanks in advance,

The problem is the -R parameter, it expects a parameter, but isn't
given one. This is a bug in the configure script. Even then, I suspect
-R is wrong (as least on Debian), it should be --runpath or
something. My Debian package includes patches that effectively disable
it, because runpaths are not needed or wanted here.
Brian May <bam@snoopy.apana.org.au>