[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: heimdal-0.5 configure and libcrypto

On 19 Sep 2002, Johan Danielsson wrote:

> Wolfgang Friebel <friebel@ifh.de> writes:
> > No, I did not understand why it fails, I do have the 0.9.6x libs
> > with the required functions.
> Do make it clear, OpenSSL 0.9.6?

No, actually: rpm -qf /usr/lib/libcrypto.a

But I tried as well plain 0.9.6, 0.9.6c and 0.9.6e with the same result
> > Could it be that -ldes should be enough to resolve the symbols.
> Where does your libdes come from? I think you need to configure krb4
> with --with-openssl=/some/dir. I suppose this should be explained
> somewhere.
No that seems not to be the problem, as the openssl libs are in the PATH
for the linker (see above). The des library comes from openafs:
rpm -qf /usr/lib/libdes.a

And as we do have a shared libcrypto.so, the symbols in libdes do not get
resolved when libdes was built (but references to e.g. MD4_init can be
found inside libdes). Therefore linking against -ldes will fail with
unresolved symbols if you do not also include -lcrypto.