[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug? Converting kaserver DB to Heimdal

Ok, this works:

/usr/heimdal/libexec/hprop --source=kaserver --cell=jpl.nasa.gov 
--kaspecials --stdout | /usr/heimdal/libexec/hpropd --no-inetd --stdin

This doesn't:

/usr/heimdal/libexec/hprop --source=kaserver --cell=jpl.nasa.gov 
--encrypt --master-key=<path to key> --kaspecials --stdout | 
/usr/heimdal/libexec/hpropd --stdin

It halts after about 2000 principals with no error indications 
whatsoever.  The databases left behind are heimdal~.* ones, not 

I guess the workaround is to just create an unencrypted database and 
then encrypt it once I'm moved over.  Or will I run into the same bug?

Another problem I ran into is that V4 instance conversion doesn't 
happen.  I only get machines converted if I can them into a 
v4_instance_convert line.

This is with version 0.6 on Solaris 8.
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
Henry.B.Hotz@jpl.nasa.gov, or hbhotz@oxy.edu