[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs and heimdal

On Wed, Aug 04, 1999 at 08:30:08AM +0200, Assar Westerlund wrote:
> That shouldn't really be necessary.  I think you still have old
> principals which have a maximum life of `0' left around.

Does this look OK?

kadmin> modify bam
Max ticket life [1 day]:
Max renewable life [1 week]:
Principal expiration time [never]:
Password expiration time [never]:
Attributes []:

> > > cvs produces the same error, but I didn't expect much since I don't have
> > > a valid ticket.
> > 
> > Same problem. I tried recompiling CVS just in case that help, but
> > no difference.
> Ok, try the appended patch to CVS and see if it's able to tell you
> more when it fails.

[526] [silas-1:bam] ~/abc/cvs-1.10.4/src >./cvs -a -x -d :gserver:snoopy.apana.org.au:/usr/local/cvsroot history                                                
cvs history: GSSAPI authentication failed:  unknown routine error
cvs [history aborted]: GSSAPI authentication failed: Server not found in Kerberos database

Arrgghhh! I knew it had to be some dumb mistake on my part ;-)

Although I don't remember seeing this before in my kdc.log file:

05-Aug-1999 08:50:15 Server not found in database: cvs/snoopy.apana.org.au@CHOCBIT.ORG.AU

Now that I have properly configured everything, it works!

[528] [silas-1:bam] ~/abc/cvs-1.10.4/src >./cvs -a -x -d :gserver:snoopy.apana.org.au:/usr/local/cvsroot history                                                
No records selected.

Brian May <bmay@csse.monash.edu.au>

PGP signature