[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Heimdal and OpenBSD 2.6


A function getaddrinfo() is returning an error -2.

	     ret = getaddrinfo (p, portstr, &hints, &ai);

p is
(gdb) p p
$25 = 0x46da0 "babble.citi.umich.edu"

and portstr is 
(gdb) p portstr
$24 = "88\000\000\000,A,(B\b@\223,Az(B\000\000\223,Az(B\000\000,ATS?_(B\000p\004\000<*\005\000\\,AH?_(B"

Both look OK to me.

On Linux, the input arguments look the same, and getaddrinfo() returns 0.
(gdb) p p
$10 = 0x8096468 "babble.citi.umich.edu"
(gdb) p portstr
$11 = "88\000\b,Aa(Br\n@\214,AT(B\027@,AP.?(B\220N\025@\037\f\b\b#\f\b\bX\000\000"

So getaddrinfo() behaves differently on Linux and OpenBSD ... ?

> Naomaru Itoi <itoi@eecs.umich.edu> writes:
> > verify_krb5_conf does not complain anything.  
> Ok, that's good.
> And I just tried using your krb5.conf and it worked fine.  So it's
> probably something else that happens, and the first thing I would
> think of is name resolution.  Do you have anything particular in your
> /etc/resolv.conf and can you try running `tcpdump -s 1500 -w /tmp/dump
> -p port 88 or port 53' so that we can figure out it you manage to look
> it up in the DNS.
> /assar