[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Heimdal 0.3e

Won't compile:

[...] ../../lib/com_err/libcom_err.la -R  -L -lcrypto ../../lib/asn1/libasn1.la ../../lib/vers/libvers.la ../../lib/roken/libroken.la -lcrypt -ldb -lresolv -lresolv 
libtool: link: only absolute run-paths are allowed
make[3]: *** [libkrb5.la] Error 1


diff -ruN heimdal-0.3e-old/configure.in heimdal-0.3e/configure.in
--- heimdal-0.3e-old/configure.in	Mon Feb  5 18:58:05 2001
+++ heimdal-0.3e/configure.in	Tue Feb  6 14:03:22 2001
@@ -566,7 +566,10 @@
 "$ac_cv_func_SHA1_Init" = "yes" -a \
 "$ac_cv_func_RC4" = "yes"; then
-  LIB_des="-R $krb4_libdir -L$krb4_libdir $ac_cv_funclib_MD4_Init"
+  if test "$krb4_libdir" != ""; then
+    LIB_des="-rpath $krb4_libdir -L$krb4_libdir"
+  fi
+  LIB_des="$LIB_des $ac_cv_funclib_MD4_Init"

Even then, it still doesn't work:

gcc -Wall -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast -Wmissing-declarations -Wnested-externs -g -O2 -o .libs/verify_krb5_conf verify_krb5_conf.o  ./.libs/libkrb5.so /old/homes/bam/heimdal-0.3e/build-tree/heimdal-0.3e/lib/com_err/.libs/libcom_err.so -lresolv -lresolv /old/homes/bam/heimdal-0.3e/build-tree/heimdal-0.3e/lib/asn1/.libs/libasn1.so -lresolv -lresolv -lresolv -lresolv /old/homes/bam/heimdal-0.3e/build-tree/heimdal-0.3e/lib/roken/.libs/libroken.so -lresolv -lresolv -lresolv -lresolv -lcrypto ../../lib/asn1/.libs/libasn1.so -lresolv -lresolv ../../lib/vers/.libs/libvers.al -lresolv -lresolv ../../lib/roken/.libs/libroken.so -lresolv -lresolv -lcrypt -ldb -lresolv -lresolv
./.libs/libkrb5.so: undefined reference to `des_new_random_key'
collect2: ld returned 1 exit status
make[3]: *** [verify_krb5_conf] Error 1

I suspect solving this will require going through Gordon's patch, and
working out what is and isn't still required (I tried applying it as
is, but got conflicts on configure.in and lib/otp_md.c).
Brian May <bam@snoopy.apana.org.au>