[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems building heimdal-0.3f --enable-kaserver

Nathan Rawling <nrawling@firedrake.net> writes:
> Hello,


> I have openssl-0.9.6 installed on the system, but I appear to be seeing some
> trouble since libcrypto is used by both krb5 and OpenSSL (unless you're
> using MIT K5 which uses libk5crypto instead). Removing libcrypto.a from
> OpenSSL from the LD_LIBRARY_PATH seemed the right thing to do. This actually
> made things significantly worse.
> Building without --with-kaserver

I assume this is actually --enable-kaserver ?  (or without both :-)

> I don't have any problems, even building
> using --with-krb4. But when I attempt to build it using --enable-kaserver, I
> get this error:

I don't see how you wouldn't get that error with --with-krb4.  But I
think you want basically this patch:

Index: kdc_locl.h
RCS file: /afs/pdc.kth.se/src/packages/kth-krb/SourceRepository/heimdal/kdc/kdc_locl.h,v
retrieving revision 1.48
retrieving revision 1.49
diff -u -w -r1.48 -r1.49
--- kdc_locl.h	2001/01/30 01:44:07	1.48
+++ kdc_locl.h	2001/06/24 00:04:11	1.49
@@ -115,4 +115,8 @@
 			     struct sockaddr_in*);
+#define des_new_random_key des_random_key
 #endif /* __KDC_LOCL_H__ */

> Has anyone else seen this problem? I've tried just about everything to work
> around it. By hacking up the kdc/Makefile I can get it to build using libdes
> from kth-krb4, but I run into problems later with telnetd and others.

You get missing references to des_* functions in telnetd?