[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems building heimdal-0.3f --enable-kaserver


I am attempting to compile heimdal-0.3f in the following environment:

	KTH Krb4 1.0.6
	GNU Readline 4.1

But I've run into the following problems:

I have openssl-0.9.6 installed on the system, but I appear to be seeing some
trouble since libcrypto is used by both krb5 and OpenSSL (unless you're
using MIT K5 which uses libk5crypto instead). Removing libcrypto.a from
OpenSSL from the LD_LIBRARY_PATH seemed the right thing to do. This actually
made things significantly worse.

Building without --with-kaserver, I don't have any problems, even building
using --with-krb4. But when I attempt to build it using --enable-kaserver, I
get this error:

gcc -Wall -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast -Wmissing-declarations -Wnested-externs -g -O2 -o kdc 524.o config.o connect.o kaserver.o kerberos4.o kerberos5.o log.o main.o misc.o  ../lib/hdb/.libs/libhdb.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket ../lib/krb5/.libs/libkrb5.a -L/usr/local/pkg/kth-krb4-1.0.6/lib /u/nrawling/build/heimdal-0.3f-afs/lib/asn1/.libs/libasn1.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket /u/nrawling/build/heimdal-0.3f-afs/lib/roken/.libs/libroken.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -ldb -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -lkrb -lcrypto ../lib/asn1/.libs/libasn1.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket ../lib/vers/.libs/libvers.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket ../lib/roken/.libs/libroken.a -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -ldb -ldb -lresolv -lnsl -lsocket -lresolv -lnsl -lsocket -R/usr/local/pkg/kth-krb4-1.0!
Undefined                       first referenced
 symbol                             in file
des_new_random_key                  kaserver.o
ld: fatal: Symbol referencing errors. No output written to kdc
collect2: ld returned 1 exit status
make[1]: *** [kdc] Error 1
make[1]: Leaving directory `/u/nrawling/build/heimdal-0.3f-afs/kdc'
make: *** [all-recursive] Error 1

Has anyone else seen this problem? I've tried just about everything to work
around it. By hacking up the kdc/Makefile I can get it to build using libdes
from kth-krb4, but I run into problems later with telnetd and others.

Thanks in advance!