[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Linux strtok_r problem


  I ran into some problems trying to run heimdal on my Linux box.
  (Red Hat 5.1 Linux 2.0.34). kdc caused a segmentstation fault every time I
  tried to use it. After much searching I found that there is a problem with 
  the version of strtok_r shipped with the system. 

  The configure script finds the system strtok_r and uses it. In order to fix 
  the problem I had to:

  1) run configure
  2) edit config.cache, changing the line strtok_r line from:




  3) run configure again.
  4) make...

  This ensures that the strtok_r that comes with heimdal is used instead.

  Note that strtok_r is in string.h which comes from the glibc-devel package.
  I'm using glibc-devel-2.0.7-13 which is what shipped with RedHat 5.1. There
  may be a newer version that fixes this problem.

  For those that are interested, here is the gdb backtrace that I used to
  find the problem:

    (gdb) run
    Starting program: /usr/heimdal/libexec/./kdc

    Program received signal SIGSEGV, Segmentation fault.
    0x4006ef52 in strtok_r ()
    (gdb) backtrace
    #0  0x4006ef52 in strtok_r ()
    #1  0x8049c99 in parse_ports (str=0x8071452 "+") at connect.c:137
    #2  0x8049e22 in init_sockets (desc=0xbffffb60) at connect.c:210
    #3  0x804a70d in loop () at connect.c:530
    #4  0x804da94 in main (argc=1, argv=0xbffffc2c) at main.c:82
 To everyone who has put so much hard work into this implementation.
 Thank you.

   - Keith
Keith Burdis - MSc (Com Sci) - Rhodes University, South Africa  
Email   : keith@rucus.ru.ac.za
WWW     : http://www.rucus.ru.ac.za/~keith/
IRC     : Panthras                                          JAPH

"Any technology sufficiently advanced is indistinguishable from a perl script"

Standard disclaimer.