[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: hpropd looping

I <LeBlanc@mcc.ac.uk> wrote:
> I do notice
> that when I run hpropd manually, it produces the message
>      hpropd: socket af = 10: Address family not supported by protocol

On Thu, Jan 27, 2005 at 07:07:38PM +0000, Dave Love wrote:
> In /etc/modutils/ipv6 I have:
>   alias net-pf-10 off
> and I don't get that message for hprop, but I do get a similar one
> from slapd for some reason.

I tried this, and it did not help.  But:

> Perhaps you could try iprop.  I don't remember why I don't have that
> running, though I currently don't have a big database.

We shall have a big database when we transfer our AFS system from
kaserver to heimdal, so in fact it makes more sense to use iprop,
which I didn't know about.  And, as a matter of fact, it seems to
work perfectly, and the instructions in the info file for setting
it up are _much_ more complete than those for hprop, so I am
currently a happy person in this respect.

I also asked about getting afslog to put the ID number in; I find
that the aklog from the Debian openafs-krb5 package works perfectly
well with heimdal, and does this by default, so I am even happier.

Thanks, Dave, for the suggestion and for your explanation about the
data base; I see more than just the last line changed; for example,
here are two entries for an iprop principal which I just created:

/tmp/rj1.dump:iprop/rj4.delta.man.ac.uk@DELTA.MAN.AC.UK 1:1:1:abbd228beb
c28443c826e9fba093e365ad610d0a5175549ec4415c:- 20050128085806:kadmin/adm
in@DELTA.MAN.AC.UK 20050128085806:kadmin/admin@DELTA.MAN.AC.UK - - - 864
00 604800 126 20050128085806:136262:2
/tmp/rj4.dump:iprop/rj4.delta.man.ac.uk@DELTA.MAN.AC.UK 1:1:1:b9fd4b0d28
bb71fa1a86a34c3daac48a93458d5ae71baba9063df3:- 20050128085806:kadmin/adm
in@DELTA.MAN.AC.UK 20050128085806:kadmin/admin@DELTA.MAN.AC.UK - - - 864
00 604800 126 20050128094256:772621:2

These look quite different to me!

     -- Owen