[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: servname not supported for ai_socktype

On Mon, 2004-03-15 at 04:06, Henry B. Hotz wrote:
> At 12:55 PM -0500 3/14/04, Robert Fitzpatrick wrote:
> >I have been trying to get LDAP backend going with no luck, now, after
> >working for a while, I am getting this error when verifying the
> >configuration file. However, using 'kadmin -l', I can list the
> >principals, but if I try to get a ticket, another error:
> >
> >esmtp# /usr/bin/verify_krb5_conf
> >verify_krb5_conf: /realms/WEBTENT.NET/kdc: servname not supported for
> >ai_socktype (
> >verify_krb5_conf: /realms/WEBTENT.NET/admin_server: servname not
> >supported for ai_socktype (
> >
> >Also, how is the best way to wipe out your setting and re-initialize a
> >realm? Can realms be deleted? Or should I just remove it from conf and
> >delete all principals?
> You could just delete the db files in /var/heimdal.  Oh, LDAP back 
> end.  Hmmm.  You don't have many principals defined yet.  Could just 
> delete all of them from LDAP with an LDAP client I suppose.

I don't have the LDAP back end setup, just trying to get Heimdal working
from start before trying that again. I wiped out the /var/heimdal and
recreate it. Then restart kerberos and kadmind and recreated all and it
seems fine now, except for the socket error when verifying, that still

Now I want to try getting the LDAP directory going again. I am using
this document to follow at http://www.padl.com/Research/Heimdal.html.
The last time I tried, after setting up the '[kdc]' section in my
krb5.conf file, kadmin complained that the database file could not be
found. I am using 'dbname = ldap:ou=Users,dc=webtent,dc=net' and it does
exist. Are there any attributes that need to be set in the OU, and does
there have to be entries in that OU?

> Before you do that though what happens if you replace the numeric 
> address with "esmtp.webtent.net" in the conf file?

Yes, I tried that and get the same error when verifying the config file.