[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ultra-modern autootols toolchain (autoconf > 2.61, automake >1.10) required?

On 2008/06/25 05:05, Brian May wrote:

> For Debian, I had problems using anything other then the latest of 
> everything, even after updating the configure.in requirements. Most 
> notable, libtool was broken; it set $echo early on but tried to use 
> $ECHO. Or vice versa. Every $ECHO statement tried to execute the message 
> instead (because $ECHO was empty), which didn't work too well.

Libtool elder than 2.2 creates configure script that defines ECHO but 
uses $echo, which is undefined. Apparently there is no other problem, 
however. So while libtool-2.2 was masked in Gentoo for problems wih many 
other packages I simply used an elder version, and then called sed to 
downcase ECHO in the generated configure. Heimdal then built and tested 

I think I've even reported that already, haven't I?

With best regards
				Honza Macháček